Author Topic: Sounds like an air leak, right?  (Read 105 times)

Offline TheDooman92

  • Trade Count: (0)
  • AMA Supersport Racer
  • **
  • Posts: 50
  • Karma: +0/-0
Sounds like an air leak, right?
« on: June 13, 2019, 02:07:30 AM »
After my bike has warmed up, the RPMs start to take longer to return to idle. However, things seem a lot better before the bike is fully warmed [HOT] (first 20-30 mins of riding) Does this sound like a vacuum leak? I believe one of the carburetor boots has a small crack, which is the cause for concern. Originally thought it was the o-rings, but now that I found a crack, I know they needs to be changed for new boots. I have ordered new boots which should be here in the next week or so. Just wanted to hear from you guys.

Offline mr72

  • Trade Count: (0)
  • MotoGP Racer
  • ******
  • Posts: 2069
  • Karma: +31/-0
  • Musician, Engineer, Sci-Fi Author
    • Josh's Books
Re: Sounds like an air leak, right?
« Reply #1 on: June 13, 2019, 11:44:54 AM »
You know you have a vacuum leak. But the symptom you describe is caused by the idle being set too high.

Offline Kilted1

  • Trade Count: (0)
  • Formula Extreme Racer
  • ***
  • Posts: 178
  • Karma: +7/-0
Re: Sounds like an air leak, right?
« Reply #2 on: June 15, 2019, 11:06:15 PM »
Could be the idle is dialed up to compensate for the vacuum leak.  Also, identifying and fixing one leak doesn't mean you don't have others.  But certainly fix the one you know about first and go from there. 

Good luck!